2010-08-23-0533Z


MrCreditRepair.biz will fix your credit rating!

Trying to install mod_python on my server, to test an automatic URL method I've had in mind. Getting the following errors:

root@tektonic:/etc/apache2# apt-get install libapache2-mod-python
Reading package lists... Done
Building dependency tree       
Reading state information... Done
libapache2-mod-python is already the newest version.
The following packages were automatically installed and are no longer required:
  librpmio0 libnspr4-0d python2.5-dev liblzma2 libelf1 libnss3-1d
Use 'apt-get autoremove' to remove them.
0 upgraded, 0 newly installed, 0 to remove and 694 not upgraded.
4 not fully installed or removed.
After this operation, 0B of additional disk space will be used.
Setting up python (2.6.5-11) ...
running python rtupdate hooks for python2.6...
Compiling /usr/lib/scons/SCons/Tool/386asm.py ...
SyntaxError: ('invalid syntax', ('/usr/lib/scons/SCons/Tool/386asm.py', 40, 9, 'import as\n'))

Compiling /usr/lib/scons/SCons/Tool/gas.py ... SyntaxError: ('invalid syntax', ('/usr/lib/scons/SCons/Tool/gas.py', 36, 9, 'import as\n'))

pycentral: pycentral updatedefault: error byte-compiling files (142) pycentral updatedefault: error byte-compiling files (142) error running python rtupdate hook pycentral WARNING: compile error while trying to byte-compile /usr/lib/aap/Filetype.py: SyntaxError: ('invalid syntax', ('/usr/lib/aap/Filetype.py', 1417, 10, ' as = 0\n'))

dpkg: error processing python (--configure): subprocess post-installation script returned error exit status 4 dpkg: dependency problems prevent configuration of python-central: python-central depends on python (>= 2.4.3-10); however: Package python is not configured yet. dpkg: error processing python-central (--configure): dependency problems - leaving unconfigured dpkg: dependency problems prevent configuration of libapache2-mod-python: libapache2-mod-python depends on python (<< 2.7); however: Package python is not configured yet. libapache2-mod-python depends on python (>= 2.6); however: Package python is not configured yet. libapache2-mod-python depends on python-central (>= 0.6.11); however: Package python-central is not configured yet. dpkg: error processing libapache2-mod-python (--configure): dependency problems - leaving unconfigured dpkg: dependency problems prevent configuration of python-dev: python-dev depends on python (= 2.6.5-11); however: Package python is not configured yet. dpkg: error processing python-dev (--configure): dependency problems - leaving unconfigured Errors were encountered while processing: python python-central libapache2-mod-python python-dev E: Sub-process /usr/bin/dpkg returned an error code (1) root@tektonic:/etc/apache2#

Bugger. Google doesn't turn up anything that looks useful.

Back to blog or home page

last updated 2010-08-23 01:39:12. served from tektonic